14 Mayıs 2019 Salı

Qt5 sitesinden yüklemek

Debian 9 Strech üstünde Lumina masaüstünü derlerken Qt5 sürümünü yükseltme ihtiyacım oldu, yoksa derlenmiyordu.
Debian sürümünde Qt5.7.1 vardı, bana lazım olansa Qt5.9.x imiş.

Neyse olayın kolay bir yöntemi varmış, Qt 'nin sayfasından indireceğimiz .run uzantılı dosya ile /opt altına kurulum oluyor.

Buradan istediğiniz Qt sürümünü çekebilirsiniz, ben 5.9.8 üzerinden gideceğim.

Not: Qt5 5.9.x kullanan Debian Buster gibi bir ortamdaysanız, büyük ihtimal ekstra QT yüklemenize gerek kalmayacaktır.  Burada yazılanlar Debian 9 içindir!
$ wget https://download.qt.io/archive/qt/5.9/5.9.8/qt-opensource-linux-x64-5.9.8.run
$ chmod +x qt-opensource-linux-x64-5.9.8.run
# ./qt-opensource-linux-x64-5.9.8.run
Kurulum adımlarını resimlerden görebilirsiniz.
Kurulduktan sonra 4.4GB gibi minicik bir yer kaplıyor. 😃

Şimdi Qt yi sisteme tanıtmak için son bir adım kaldı, /etc/xdg/qtchooser dizininiz yoksa oluşturun, varsa dosyayı düzenleyin.
# mkdir /etc/xdg/qtchooser
# nano /etc/xdg/qtchooser/default.conf
Bu dosyanın içine indirdiğimiz Qt nin yolunu yazıp kaydedelim.
/opt/Qt5.9.8/5.9.8/gcc_64/bin
/opt/Qt5.9.8/5.9.8/gcc_64/lib
Değişiklik anında görünür.

$ qmake -v
QMake version 3.1
Using Qt version 5.9.8 in /opt/Qt5.9.8/5.9.8/gcc_64/lib

Son olarak eğer 5.9.8 sürümünü iptal etmek isterseniz /etc/xdg/qtchooser/default.conf dosyasını silmeniz veya sonuna -ydk gibi bir ek yaparak, etkisiz hale getirebilirsiniz. Sonra da isterseniz /opt/Qt5.9.8/ tamamen silebilirsiniz.
default.conf-ydk

Normalde sistem ilk önce  /etc/xdg/qtchooser dizinin okuduğu için, paket olarak kurduğumuz Qt/QMAKE ler görünmüyormuş.

 




Benzer Yayınlar

Qt5 sitesinden yüklemek
4/ 5
Oleh

Abone Olun!

Beğendiyseniz yayınlara abone olabilirsiniz.