3 Mayıs 2012 Perşembe

FreeBSD'ye Kamera (WebCam) tanıtmak

** FreeBSD 9.2 ve üstü kullanıyorsanız buraya bakınız..

Önce Webcam takılı olsun ve ugen'ini bulun.
# usbconfig
ugen0.1: <OHCI root HUB nVidia> at usbus0, cfg=0 md=HOST spd=FULL (12Mbps) pwr=SAVE
ugen1.1: <EHCI root HUB nVidia> at usbus1, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=SAVE
ugen2.1: <OHCI root HUB nVidia> at usbus2, cfg=0 md=HOST spd=FULL (12Mbps) pwr=SAVE
ugen3.1: <EHCI root HUB nVidia> at usbus3, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=SAVE
ugen1.2: <Acer CrystalEye webcam SuYin> at usbus1, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON
ugen2.2: <USB Mouse A4Tech> at usbus2, cfg=0 md=HOST spd=LOW (1.5Mbps) pwr=ON
...
Benim webcam'in ugen1.2 bunu not ediyoruz, tabii sizde daha başkadır onu not edin.

Bu 5 paketi sisteminizde kurulumu kontrol edin, değilse olmayanları kurun.
$ pkg_info -Ex v4l_compat libv4l pwcview cuse4bsd webcamd
cuse4bsd-kmod-0.1.23
libv4l-0.8.4_1
pwcview-1.4.1_4
v4l_compat-1.0.20110720
webcamd-3.5.0.2

/boot/loader.conf'a ekleyin.
cuse4bsd_load="YES"

/etc/rc.conf'a ekleyin.
webcamd_enable="YES"

restart devd
# /etc/rc.d/devd restart

Modülü yükleyin
# kldload cuse4bsd

/usr/local/etc/rc.d/webcamd bu dosyayı açın ve altaki değişimi yapın.
Bul ;
command_args="-B -U webcamd -G webcamd"

Değiştir ;
command_args="-B -U root -G operator"

** Eğer /usr/local/etc/rc.d/ dizini içinde webcamd~ diye yedek dosyası oluşmuşsa onu silin.

Not ettiğiniz ugen'e göre bu komutta ki ugen'i değiştirip verin.
# webcamd -d ugen1.2 -i 0 -v 0

Şimdi normal bir konsol açıp webcam testini konsoldan yapın, kendinizi görüyorsanız işlem tamamdır.
$ pwcview

Ayrıca buradan da tarayıcınız ile de çeşitli testleri yapabilirsiniz.

Son olarak sisteminizi yeniden başlattıktan sonra, emin olmak için bir test daha yapınız.

Çözümler ;
Eğer pwcview ile böyle bir hata alırsanız sistem izleyici ile flashpluginplayer modülünü durdurun.
(Bu modül opera için operapluginwrapper'dir)
$ pwcview
libv4l2: error setting pixformat: Device busy
libv4l1: error setting pixformat: Device busy
Failed to set palette to YUV420P: Device busy

İlişki kaynak; USB aygıt Aç/Kapa | BSD

Yararlanılan Kaynaklar ;
http://www.selasky.org/hans_petter/video4bsd/
http://www.rockafunk.org/InstallWebcamd.html
http://forums.freebsd.org/showthread.php?t=15224
http://forums.freebsd.org/showthread.php?t=15224
http://www.daemonforums.org/showthread.php?p=43807

Benzer Yayınlar

FreeBSD'ye Kamera (WebCam) tanıtmak
4/ 5
Oleh

Abone Olun!

Beğendiyseniz yayınlara abone olabilirsiniz.

7 yorum

yorum
avatar
docttur
9 Eylül 2012 14:09

Bende(pc-bsd 9.0) cuse4bsd zaten yüklü./etc/rc.conf da webcamd_enable="YES"
satırı var.
/usr/local/etc/rc.d/webcamd dosyasında
"command_args="-B -U webcamd -G webcamd" satırını buldum ve burada hiçbir değişiklik yapmadan tarayıcıda webcam'ı denedim.Gayet düzgün çalıştı.Fakat;
$ pwcview komutunda kendi görüntümü görüyorum.Fakat kısa bir süre sonra donuyor ve tam siyah tam ekran oluyor.(Görüntü kayboluyor)Bu sırada webcam'ın çalıştığını gösteren mavi ışık sürekli yanıyor.Öylece donup kalıyor.Masaüstüne ulaşamıyorum.Yani kilitlenip kalıyorum.Ancak aç-kapa düğmesiyle sistemi yeniden başlatabiliyorum.

Sonra "command_args="-B -U webcamd -G webcamd" satırında belittiğiniz gerekli değişikliği yaptım.Tarayıcıda test ederken sorun yok.Fakat
$ pwcview ile aynı şekilde kilitleniyorum.

Cevapla
avatar
felasife
9 Eylül 2012 17:09

Hımm.. sanırım ya bir çakışma var ya da ekran kartı sürücüsünde bi problem var.

# usbconfig
$ pkg_info -Ex v4l_compat libv4l pwcview cuse4bsd webcamd
$ cat /var/log/messages | tail -n30
$ cat /var/log/Xorg.0.log | grep -e EE -e WW

Önce bunlara bi bakalım ona göre hareket ederiz.
Bu çıktıları http://ompldr.org/ 'a pasta edersek iyi olur.

Cevapla
avatar
docttur
9 Eylül 2012 21:09

Çıktılar
http://ompldr.org/vZmZkeA

Cevapla
avatar
felasife
10 Eylül 2012 14:09

@doctur, geç cevap için kusura bakma dün biraz tansiyon problemim vardı, neyse çıktılarına bakınca ilk gözüme çarpan v4l_compat paketi kurulu değil onu bi kuralım.
# pkg_add -r v4l_compat
Sonrada sistemi yeniden başlatalım.
xorg.conf'ta şu satırlar sorun yaratır mı açıkcası bilmiyorum ama istersen bi araştır zira bende ATI olamayınca etkilerini bilemiyorum, diğer satırlar önemli bir problem çıkartmayacaktır onu söyleyebilirim ama.
(WW) RADEON(0): LVDS Info:
(WW) RADEON(0): DRI init changed memory map, adjusting ...
(WW) RADEON(0): MC_FB_LOCATION was: 0x7fff7800 is: 0x7fff7800
(WW) RADEON(0): MC_AGP_LOCATION was: 0x003f0000 is: 0x81ff8000
Birde sanırım webcam tak/çıkar özellikli başka bir yuvaya takıp dener misin?
Sanki bana 3G adaptörüyle çakışıyor gibi geldi ama önce v4l_compat bi kur dene bakalım, değişiklik olacak mı?

Cevapla
avatar
docttur
10 Eylül 2012 16:09

Durum değişmedi.Tarayıcıda ve kopete mesajlaşmada düzgün çalışıyor.Sadece pwcview ile çalışmıyor.Gerçi webcam'ı pek kullanmıyorum.Onun için pek sorun değil şimdilik.Ayrıca webcamım notebook üzerinde monte, onun için usb portunu değiştiremiyorum.Turkcell VINN usb 3g adaptörünü çıkardıktan sonra da durum değişmedi.

Cevapla
avatar
felasife
10 Eylül 2012 17:09

Hımm.. anladım, sadece pwcview de sorun çıkıyorsa o zaman fazla kurcalamayalım, kalabilir böyle.

Cevapla
avatar
anonymous
7 Ocak 2013 01:01

doctur writes:

Sanırım sorun ati video sürücüsüne bağlı. Vesa sürücüsünü kulla
nınca sorun kalkıyor ve pwcview de düzgün çalışıyor.

Cevapla