FreeBSD ye resmi PKGNG desteği geldi.

FreeBSD ye resmi olarak PKGNG desteği gelmiş durumda.Artık
8.3, 8.4, 9.1, 9.2, 10.0 ve 11 sürümlerinde i386 veya amd64 olarak isterseniz aktif edip kullanabilirsiniz.
FreeBSD 10.0 sürümündeyse zaten varsayılan olarakta kullanılabilecekmiş. ...
Daha önce burada anlattığımız gibi PKGNG kullanılabiliyordu, lakin yeni duyuruya göre olay biraz daha değişmiş durumda.
Tabii PKGNG yi kullanmak istemiyorsanız önceki sistemi kullanmaya devam edebilirsiniz.

Öncelikle pkg paketini pkg -v veya pkg_info -Ex pkg ile kontrol edin.
(En az sürüm no'su 1.1.4_8 olsun, daha aşağı bir sürümse kaldırın ve porttu güncelleyin ve porttan kurun.)
# portsnap fetch update
# cd /usr/ports/ports-mgmt/pkg ; make install clean
# echo WITH_PKGNG=yes >> /etc/make.conf
# pkg2ng

Ardından /usr/local/etc/pkg.conf dosyasında açık olan satırları diyez (#) le kapatın..
# mkdir -p /usr/local/etc/pkg/repos
# touch /usr/local/etc/pkg/repos/FreeBSD.conf

Altakileri FreeBSD.conf isimli bir dosyaya root ile yerleştirin.
FreeBSD: {
url: "http://pkg.FreeBSD.org/${ABI}/latest",
mirror_type: "srv",
enabled: "yes"
}


Artık paketlerimizi güncelleyebiliriz.
# pkg update ; pkg upgrade


Notlar:
* İlk güncellemede sadece pkg kurulursa, onu kurduktan sonra komutu tekrar verin.
* İlk güncellemede güncelleme boyutu fazla olabilir PKGNG de artık buna alışmalısınız..
* perl paketinide sorun yaşarsanız /usr/ports/UPDATING dosyasına bakınız !
(normalde her türlü kurulum sorunlarında ilk önce bu dosyaya bakın, genelde çözümleri vardır)


Hayırlı olsun. :flirt:

Hiç yorum yok:

Yorum Gönder

2010 - 2022 Beastie BSD Türkiye