FreeBSD resmi olmayan (Unofficial) paketler


FreeBSD nin resmi olarak desteklenmeyen ama genede kullanıcılara açılmış olan Unofficial paketleri bulunmaktadır.
Burada en yeni derlenmiş FreeBSD-Unofficial-Packages 'e veya daha eski FreeBSD Archive 'ye ulaşabilirsiniz. ...
Bkz. Index of / http://ftpmirror.your.org
http://ftpmirror.your.org

Tabii resmi olarak desteklenmediği için olası sorunları kendiniz çözmek durumundasınız, neticede en güvenli yol paketleri kendiniz derlemenizdir.
BSD 'e geçtim geçeli niyeyse icedtea-web uygulamasını hiç bir zaman porttan derleyerek kuramadım, sanırım dil ile veya bilemediğim başka bir sorun yüzünden oldu bilemiyorum ama kurmadım gitti, dolayısıyla hep pkg_add ile kurabildim kendisi.
Böyle olunca da örn. FreeBSD 9.1 Stable kullansam da portta son sürüm 1.4 olsa bile, anca 1.3 kurabiliyordum.
Neyse ki bu FreeBSD Unofficial Packages sayesinde ilk kez 3 yılı aşkındır  icedtea-web 'in son sürümünü kullanabildim.

Olayın diğer yönüde LibreOffice, Chromium, Firefox gibi saatlerce süren derlemelere de FreeBSD Unofficial Packages sayesinde çokta gerek kalmamasıdır, son sürüm varsa .tbz paketini indir kur bu kadar.
örn.
# pkg_add xxxxxx.tbz

xxxx olan yere indirdiğiniz paketin ismi yazılacak..  

Desteklenen mimari ve sürümler ;
9.1: i386 amd64 i386-mini amd64-mini i386-pkgng amd64-pkgng ia64
9.0: i386 amd64
8.4: i386 amd64
8.3: i386 amd64
8.2: i386 amd64
8.1: i386 amd64
8.0: i386 amd64
7.4: i386 amd64
7.3: i386 amd64
7.2: i386 amd64
Görüldüğü üzere 9.1 sürümünde pkgng de destekleniyormuş.


Eğer FreeBSD Unofficial Packages 'i csh konsolda depo olarak eklemek isterseniz.
setenv PACKAGESITE http://ftpmirror.your.org/pub/FreeBSD-Unofficial-Packages/xxxxxx-default/Latest/


Kalcı olsun derseniz.
echo 'setenv PACKAGESITE http://ftpmirror.your.org/pub/FreeBSD-Unofficial-Packages/xxxxxx-default/Latest/' >>/etc/csh.login

xxxxxx olan yere kullandığınız sürümü ve mimariyi yazmalısınız.. örn. FreeBSD 9.1  64-bit için 91amd64 veya 32-bit için 91i386 gibi

İndirdiğiniz paketi kurmadan önce eski versiyonu kaldırmanız gerekir, olası bağımlılık sorunları içinde pkgdb -Fu kullanabilirsiniz.

Dediğim gibi bu olayın riskleri vardır, bunu unutmayınız..

Kolay gelsin..

Hiç yorum yok:

Yorum Gönder

2010 - 2022 Beastie BSD Türkiye